Skip to main content
Mitratech Success Center

Third Party Software Support

Third Party Software Support
The following matrix represents the third party software products support with each release of TeamConnect(6.2 and further). Third party software includes application servers, databases, browser version and so on.

Third Party Support Guidelines  

To access the Third Party Software Support matrix for older versions(prior to 6.2) of TeamConnect, refer to  SupportMatrices_TC4_to_6.2

TeamConnect

Client Browsers

 

Product Version NEW
7.0
6.3.7 6.3.6 6.3.5 6.3.4 6.3.3 6.3.1 6.3 6.2.7 6.2.5 6.2.4 6.2.2 6.2.1 6.2
Release Date 9/29/22 08/09/22 04/29/22 02/22/22 12/07/21 8/6/21 5/7/21 Feb 2021 10/18/21 Nov 2020 8/28/20 4/15/2020 11/22/19 9/12/19
Chrome Current

Safari (Only on Mac OS - Catalina version)

Current
FireFox Current
Microsoft Edge

 
Edge Chromium (Anaheim)
Edge (Spartan)                          
Internet Explorer 11 (works with Windows 8.1)                     No longer supported
Database Servers Product Version    7.0 6.3.7 6.3.6 6.3.5 6.3.4 6.3.3 6.3.1 6.3 6.2.7 6.2.5 6.2.4 6.2.2 6.2.1 6.2
Oracle

 
19c      
12c R2                  

12c

                           
SQL Server (Windows only) 2019            
2017                  
2016 SP1                          
Java Application Servers Product Version    7.0 6.3.7 6.3.6 6.3.5 6.3.4 6.3.3 6.3.1 6.3 6.2.7 6.2.5 6.2.4 6.2.2 6.2.1 6.2
Oracle Weblogic 12c R2 (12.2.1.4) w/ Oracle jdk1.8.0_281            
12c R2 w/ Oracle JDK 1.8 (build 202)                  

12c R1 w/ Oracle JDK 1.7 (1.8 only for 12.1.3)

                           
Websphere Websphere Liberty 21.0.0.12 w/ Oracle OpenJDK 11 (jdk-11.0.6)                        
Websphere Liberty 20.0.0.9 w/ Oracle OpenJDK 11 (jdk-11.0.6)            
9.0.0 w/ Oracle JDK 1.8                  
Tomcat
 
9.0.22 w/ Oracle OpenJDK 11 (jdk-11.0.6)
8.5 w/ Oracle JDK 1.8                          
Reporting Product Version    7.0 6.3.7 6.3.6 6.3.5 6.3.4 6.3.3 6.3.1 6.3 6.2.7 6.2.5 6.2.4 6.2.2 6.2.1 6.2
Sisense 8.2.1                      

8.2

(TCBI Version 6.2.4 and above)

           

7.1.0.11010

(TCBI Version 6.1 through 6.2.2)

                     
Business Objects 4.2 SP9                     
4.2 SP8        
4.1 SP4                    
Other Product Version    7.0 6.3.7 6.3.6 6.3.5 6.3.4 6.3.3 6.3.1 6.3 6.2.7 6.2.5 6.2.4 6.2.2 6.2.1 6.2
SAML 2.0 SAML 2.2.1
SAML 2.2.0 (open jdk)                        
SAML 2.0 (jdk 8)            
Elasticsearch

 
7.16.3
Includes log4j 2.17.1
                     
7.10.2                  
7.1.1                  
5.4                            
MS Office

2019

     

Office 365 Plus (or) Microsoft 365 Apps for enterprise

2016
2013                            
SharePoint Online  
iManage v2 10.x +
iManage v1 8.5 - 9.x                        
CSC SOP 7.0.0                          
CSC SOP 5.1.1    
CT SOP  

Web Servers 

Product Version    7.0 6.3.7 6.3.6 6.3.5 6.3.4 6.3.3 6.3.1 6.3 6.2.7 6.2.5 6.2.4 6.2.2 6.2.1 6.2
IIS 8.5           No longer supported

Client OS 

 

Product Version    7.0 6.3.7 6.3.6 6.3.5 6.3.4 6.3.3 6.3.1 6.3 6.2.7 6.2.5 6.2.4 6.2.2 6.2.1 6.2
Windows 10
8.1                            
8                            
7                            

Mac OS X

(Only on Safari browser)

Big Sur (11)                    
Catalina (10.15.6)                  
Mojave (10.14.1)                  
Sierra (10.12.6)                            
El Capitan(10.11)              

 

           
Third Party Libraries   Updating vulnerable and outdated libraries                        
Data Warehouse with Oracle OpenJDK 11/JDK 1.8                  
Screen Designer with Oracle OpenJDK 11/JDK 1.8                  
Authentication Google Authenticator Browser Version (6.3.3)              
Android App Version (5.1)              
iOS App Version (3.4)              

Note:

  • Sisense does not support Microsoft Edge. While Mitratech has tested the TeamConnect Business Intelligence with Microsoft Edge, Mitratech cannot be responsible for supporting any issues that occur. 
  • Sisense 8.2 and Sisense 8.2.1 supports Java 1.8 (We recommend to use certified JVMs like Oracle and OpenJDK only.)
  • SAML 2.2.1 is backward compatible with SAML 2.0

Office Suite Matrix

Product Version 2.2.1 2.2.2 3.0 3.1 3.1.1 3.2.0 3.2.1 3.2.1.7 3.3.0
Microsoft Office and Outlook 2019                
Office 365 ProPlus (or) 
Microsoft 365 Apps for enterprise
   
2016
2013              
Product Version 2.2.1 2.2.2 3.0 3.1 3.1.1 3.2.0 3.2.1 3.2.1.7 3.3.0
TeamConnect 5.2              
6.0.2    
6.1      
6.2              
6.2.1              
6.2.2              
6.2.3              
6.2.4            
6.2.5            
6.2.6            
6.3            
6.3.1            
6.3.2            
6.3.3            
6.3.4            
6.3.5            
6.3.6            
6.3.7            
7.0            
Product Version 2.2.1  2.2.2  3.0 3.1 3.1.1 3.2.0 3.2.1 3.2.1.7 3.3.0
Minimum .NET Version 4.5.2        
4.7.1              
4.7.2