"Invalid Value for Country Code" Error
Summary
A user is unable to complete E-Verify for an employee because the system is stating there is an invalid country code. In this example, the country is Hong Kong. While the USCIS allows Hong Kong to be used as the country of issuance for a Foreign Passport on the Form I-9, E-Verify does not allow Hong Kong (HKG) to be used as the country for the E-Verify case.
Cause
The E-Verify system will present this error message with a list of acceptable country codes when a code is used that they do not accept. This is due to the inconsistencies between USCIS rules for the Form I-9 that allow a larger selection of options for the issuing country for a foreign Passport, and E-Verify's more limited list of acceptable countries.
Resolution
The solution for this per E-Verify's compliance organization is to use China as the country for the E-Verify, which may be edited on the E-Verify Preview Page where an error message appears. However, the country in Section 2, in this example Hong Kong, may remain in use for Section 2 of Form I-9.
Other countries with this issue may have a similar resolution.
Known Issuing Authorities with this issue
These are the Issuing Authorities Mitratech is currently aware of where E-Verify requires a different country be used as the Issuing Authority when submitting the E-Verify case. This is not a complete list of all Issuing Authority countries where this may happen because E-Verify has not supplied a complete list. The Tracker I-9 Support Team will update list as we learn of more Issuing Authorities countries where a different Issuing Authority should be used.
- China Should be used for:
- Hong Kong
- The United Kingdom should be used for:
- Anguilla
- Bermuda
- British Antarctic Territory
- British Indian Ocean Territory
- British Virgin Islands
- Cayman Islands
- Falkland Islands
- Gibraltar
- Montserrat
- Pitcairn Islands
- Saint Helena, Ascension and Tristan da Cunha
- South Georgia and the South Sandwich Islands
- Turks and Caicos Islands