TeamConnect Available Updates fails to load.
Problem Summary:
Unable to retrieve updates. There may be a problem connecting to the internet or host server
SystemSettingsEditController.showAvailableUpdatesAction - Could not send Message.
com.mitratech.teamconnect.core.service.ProductUpdateException: Could not send Message.
at com.mitratech.teamconnect.core.service.impl.ProductManagementServiceImpl.readAvailableProductUpdates(ProductManagementServiceImpl.java:240)
Caused by: javax.xml.ws.WebServiceException: Could not send Message.
at org.apache.cxf.jaxws.JaxWsClientProxy.invoke(JaxWsClientProxy.java:150)
Caused by: java.net.ConnectException: ConnectException invoking https://maestro.teamconnect.com/maes...jectRepository: Connection timed out: connect
Cause :
Maestro IP address changed recently and need to update at Firewall end.
Resolution
To find out the maestro IP , try in command prompt with this command : "nslookup maestro.teamconnect.com"
So, need to update the IP address of Maestro at their firewall to resolve this issue.