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"Invalid Value for Country Code" Error

This shows what a user should do for the E-Verify "Invalid value for country code" error.

Summary

A user is unable to complete E-Verify for an employee because the system is stating there is an invalid country code. In this example, the country is Hong Kong. While the USCIS allows Hong Kong to be used as the country of issuance for a Foreign Passport on the Form I-9, E-Verify does not allow Hong Kong (HKG) to be used as the country for the E-Verify case.

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Cause

The E-Verify system will present this error message with a list of acceptable country codes when a code is used that they do not accept. This is due to the inconsistencies between USCIS rules for the Form I-9 that allow a larger selection of options for the issuing country for a foreign Passport, and E-Verify's more limited list of acceptable countries.  

Resolution

The solution for this per E-Verify's compliance organization is to use China as the country for the E-Verify, which may be edited on the E-Verify Preview Page where an error message appears. However, the country in Section 2, in this example Hong Kong, may remain in use for Section 2 of Form I-9.

Other countries with this issue may have a similar resolution.

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