CSM sync issue - Related to Rate request
Problem Summary
When a vendor Reaches the Client saying that they have submitted a Rate request Long back and still see the status as "Pending Client Retrieval"
So there might be the CSM sync issue in Rate Request Synchronization And in the Logs we see:
2021-05-20 12:44:14,017 [system] [DEBUG] [rule] CollaboratiKey.debug - [CSM] creating new rate request item from Collaborati...
2021-05-20 12:44:14,031 [system] [DEBUG] [rule] CollaboratiKey.debug - [CSM] Could not find timekeeper with guid: TKR-29f51251-bbaf-4597-905f-08d807c8c341
2021-05-20 12:44:14,040 [system] [INFO] [rule] CollaboratiKey.info - [CSM] CSM baseline version 6.2.0
2021-05-20 12:44:14,040 [system] [ERROR] [rule] CollaboratiKey.error - [CSM] Error syncing new rate request with id: RTR-0ddb9fb4-3229-4670-a3ee-a71113497b7e
RateRequestException: Timekeeper from collaborati rate request com.mitratech.collaborati.rest.client.v1.model.ClientRateRequestAmount@7c6a96a7 was not found in TeamConnect
at SyncRateRequestProcess.createTCRateRequestItem(SyncRateRequestProcess.java:243)
Cause
This issue occurs when there is any mismatch of the Timekeeper(s) GUID and the vendor submits Rate request for those Timekeeper(s)
Resolution
We need to Find out the Timekeeper(s) in TeamConnect and then we need to clear Timekeeper(s) GUID to fix the issue.