MITRATECH

TeamConnect® Enterprise

7.0 Patch Bundle 7
Release Notes

TeamConnect® Enterprise 7.0 Patch Bundle 7 (PTC7000007) resolves the following issue.

NOTE: This patch also includes fixes from TCE 7.0 PB1, TCE 7.0 PB2, TCE 7.0 PB3, TCE 7.0 PB4,
TCE 7.0 PB5 and TCE 7.0 PB6.

Improvement: In Invoice and My Approval pages, the column width persists as per the user
preference.

Description: When a user modifies a column width, whether it is default or optional, the column width
setting is saved to the user's preference and the value is saved in the database. For more information,
click the Invoice page and My Approval page.

Tracking Code: TC-39978, TC-40089

Improvement: In the Invoice page, the selected "View" persists in invoice review.

Description: In the Invoice page, the persistence configuration is specific to Invoice Review. If the user
changes the "view" value, their preferences will take precedence over the default and the page will
always load with the desired configuration. For more information, click here.

Tracking Code: TC-49917

Issue: Validation Rule Not Triggered on 'ls Contains' Logic When we add more than one record which
contains restricted value.

Tracking Code: SUPPORTPRI-68659

Case Number: 2023-0626-7891754

Reported Version: TCE 7.0

Workaround
Possibly make a custom action.

Pre-Requisites
NA

Steps to Reproduce

1. Create a custom object (user can use an existing object if you want) - This shall be called the
'Parent Object'.

2. Create a child object called 'Allegation Table'.

3. Go to the custom field tab and create a custom field called 'Allegation Code'. It is a "Text' field

type.
4. Go to the Search View tab and create a search view called 'Allegation Code Table'
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https://success.mitratech.com/@api/deki/files/70993/TCE700_PB1_ReleaseNotes.pdf?revision=2
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https://files.mtstatic.com/site_11424/draft_71529/0?Expires=1703252277&Signature=OST7~U0tzbHbSSZmSffk8G7TfBRVgqPO7xtRvic~lt-DbsYeqp7gRs1g298muKPChA7Y1vWf4nKu6bfkmFxQjuN8nVjvgoX9Q8XPr9PzbSYRQvE0RpAGYPCLR-4jImc6KYIDYNoCwv0zgO~ug11KDfcUB8E7nqcUdcWyYSKfWPQ_&Key-Pair-Id=APKAJ5Y6AV4GI7A555NA
https://files.mtstatic.com/site_11424/draft_72055/2?Expires=1703252293&Signature=aKX6pkJb~yX7fVKHnYjfE70A5T6ALlRJ27WKmR7dziYLEuIxApwddAsxYzMcHQVe7dqrniVW9w~w8iyvkOtcUG4J74x71WnX~dn9oo4rooBZCo8mjotVDOxX7VfkwJzouBXi2YMv0OmFpVKmSGYB3Vvon8DtG4-rBlBYiTqnDsA_&Key-Pair-Id=APKAJ5Y6AV4GI7A555NA
https://files.mtstatic.com/site_11424/draft_72928/0?Expires=1703252311&Signature=S6mubRCFmIlgy4OLPOSz2kmkvp~zpjU72jN~tlcitvnv0GiuwQ1vAPpo-tDO8x66mBZRR7At1rteqOjRjFhtrXxzxj2uD7ABOPsxP5MAB7oke5GZuCvgMFRZfpnBWtJJ0fcYnHHIH34j0dGvmf-rFBjfBfT1duZuj4IGEyrTV7o_&Key-Pair-Id=APKAJ5Y6AV4GI7A555NA
https://files.mtstatic.com/site_11424/draft_73271/0?Expires=1703252326&Signature=hjRoWLQLRe5dJiyt~fKStXGv3~uAidYMMkUqqLxZSebcniPhxaxPvUYQ1EWKClvvppGf7RntckwY8QTPERekeITZF4Lp2F~mU3Yh9Po7hTyrlVl6rX9JblBGQWIUZK-N0XjLLKI3hDjoB1dfyma4tpF2h0LpQTF~xPh~xNXfCrQ_&Key-Pair-Id=APKAJ5Y6AV4GI7A555NA
https://success.mitratech.com/TeamConnect/Enterprise_User_Guide/Finance/Interactive_Invoice_Review-End_User_Guide#Column_Width_persistence:~:text=to%20standard%20values.-,Column%20Width%20persistence,-In%C2%A0TCE
https://success.mitratech.com/TeamConnect/Enterprise_User_Guide/Finance/Interactive_Invoice_Review-Admin_Guide/My_Approvals#Column_Width_persistence:~:text=Rights%20%3E%20View%20%3E%20Invoice-,Column%20Width%20persistence,-In%C2%A0TCE
https://success.mitratech.com/TeamConnect/Enterprise_User_Guide/Finance/Interactive_Invoice_Review-End_User_Guide#Column_Width_persistence:~:text=search%20view%20selected.-,Persistence%20of%20selected%20%22View%22%20in%20Invoice%20Review,-After%20TCE%207.0

a. Should be a Search Module with Auto Search On.
b. Filter Display should include the Name, Number, and Allegation Code field.
c. Results Display should include an object link, Name, Number, and Allegation Code field
Go to the Parent Object.
Go to the Embedded tab.
Create a new embedded object called 'Allegation Event'.
Go to the Custom Field tab and create a custom field.
a. The field name is 'AllegationType'.
b. The label is 'Allegation Code'.
c. The field type is a custom object linking to the 'Allegation Table' child object.
d. The Search View is the 'Allegation Code Table' view
9. Click the List Display tab and add the following:
a. Name, Number, Allegation Code (refers to the AllegationType display key)
10. Go to the Parent Object.
Create a rule called 'Qualifier Check' - Unique key = 'QACK'
Set the rule type to Validation.
Activate the rule.
Set the trigger to 'Update’.
Set the qualifier to Current Object -> Child List -> Allegation Event -> DetailList ->
Allegation Event -> Allegation Type -> DetailList -> Allegation Table -> Allegation Code.
f. Set the operator to 'ls Contains' and put 'Walk' in the right argument.
g. Click the Action tab and put in a rejection message
11. Go to the parent object and add the child object to your parent object view.
12. Go to the TeamConnect Application.
13. Make sure you add the child object and embedded object to your group permissions.
14. Go to the 'Allegation Table' child object.
a. Add a record named 'AT - Walk' with an allegation code of 'Walk'.
b. Add a record named 'AT - Run' with an allegation code of 'Run’
c. Add arecord named 'AT - Skip' with an allegation code of 'Skip'
15. Create a new parent record.
a. Within the parent record, add three Allegation Events:
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i. AT-Walk
i. AT-Run
ii. AT - Skip
b. Save.
c. Edit the record and remove either 'AT - Walk' or 'AT - Skip'.
d. Save.

e. Observe the rule does not fire.
Remove all of the Allegation Events
- Save
- Edit the record and add 'AT - Walk'
- Save
- Observe the rule fires but the 'AT - Walk' is still added
- Add 'AT - Run'
- Save
- Observe the rule is not triggered
Remove all of the Allegation Events
- Save
- Add the embedded records and add 'AT - Walk' and 'AT - Run"
- Save
- Observe the rule is not triggered and both embedded records are added.
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Expected Results of Steps
The rule should fire because the prohibited text is there.

Actual Results of Steps

When there are multiple embedded records (and at least one of them includes prohibited text defined in
the rule), rule does not fire and the parent record is saved. In the client's previous version, the rule was
triggered and prevented prohibited values from being entered.

Additionally, when there is only one embedded record (that contains the prohibited text as defined in the
rule), the rule will trigger but the embedded record will be added anyway. If the rule is triggered, the
embedded record should not be added.

Root Cause Analysis
None.

Issue: Screen reader does not announce column sorted.
Tracking Code: SUPPORTPRI-69058

Case Number: 2023-0920-7992706

Reported Version: TCE 7.0

Workaround
None.

Pre-Requisites
Screen reader on.

Steps to Reproduce

1. Login to TeamConnect developer environment.
2. In the home page click the Column headers > My Open Matters table and sort by
ascending/descending.The state is not read by the screen reader.

Expected Results of Steps
Screen reader reads the sorted state to the user.

Actual Results of Steps
Screen reader does not read the sorted state.

Root Cause Analysis
The implementation was not there in the application and had to be introduced in the code base.

Issue: Client reporting similar Accessible Names for interactive controls that are causing issues.
Tracking Code: SUPPORTPRI-69060

Case Number: 2023-0920-7992681

Reported Version: TCE 7.0

5001 Plaza on the Lake | Suite 111 | Austin TX 78746



Workaround
None.

Pre-Requisites
Have a TeamConnect Environment.

Steps to Reproduce
First Issue:
1. Login to TeamConnect developer environment.
2. Go to the Legal tab and open the matters.
3. Hover on the edit button and it shows edit instead of accessible names. Screen reader users
may have difficulty determining the function of the button.
Second Issue:
1. Login to TeamConnect developer environment.
2. Go to the Home page and the minimize/maximize button is not having exact accessible names.

Expected Results of Steps
Accessibility Names are different enough to not cause confusion.

Actual Results of Steps
Accessibility Names are not clear to users.

Root Cause Analysis
None.

Issue: User is unable to view Admin Settings view page.
Tracking Code: SUPPORTPRI-67013

Case Number: 2023-0225-7692292

Reported Version: TCE 6.3.5

Workaround
None.

Pre-Requisites

TCE version 6.3.5 with patch 10 applied.

Create a group and assign it to a user.

Select the group you have created. Click on System Rights.

Under System Rights > View dropdown, select Admin Rights and then select All admin view
rights.

Under View dropdown, select Admin Settings.

Now select only View Admin Settings records and save it.

PO~
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Steps to Reproduce

1. Login to the user you have created.
2. Under Home Page, click on Admin Settings.

Expected Results of Steps
User needs to have the view option of Admin Settings.
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Actual Results of Steps
Error Page with message A system error has occurred.

Root Cause Analysis
Incorrect bean property name used in jsp page.

Issue: Rule validation Error messages are not triggering for interactive line items.
Tracking Code: SUPPORTPRI-69115

Case Number: None

Reported Version: TCE 7.0 PB6

Workaround
None.

Pre-Requisites
None.

Steps to Reproduce

Must have a validation rule on Line Item to not allow Unit/Rate.
Go to an invoice > Interactive Line Items.
Do a Unit/Rate Adjustment.

PO~

The error must be thrown on the screen as a red banner, but upon adjustment, the screen

freezes and the error is not thrown. Occasionally the page crashes and logs out the user.

Expected Results of Steps
System shows error messages.

Actual Results of Steps
System doesn't show error messages.

Root Cause Analysis
None.

Issue: "A System Error Has Occurred" page displayed on login for first time via SSO.

Tracking Code: SUPPORTPRI-69062
Case Number: 2023-1018-8025239
Reported Version: TCE 7.0

Workaround
None.

Pre-Requisites
e SAML 224
e SSO enabled User
e Preference "Enable Time Zone Sync" enabled

5001 Plaza on the Lake | Suite 111 | Austin TX 78746



MITRATECH

Steps to Reproduce

Log into application through SSO.

Expected Results of Steps
Login to the TC environment via SSO in the first attempt.

Actual Results of Steps
User is sent to the 'FatalAuthenticationError.jsp' page. If a user clicks the login link again, they are
directed to the homepage (already asserted by SAML).

Root Cause Analysis

Avoiding NPE.

The fixes in this patch will be merged into TCE 7.2

INSTALLATION

Important: Stop your TeamConnect® instance before updating any files in the TeamConnect® war file.

1. Replace WAR file

This patch requires replacing the entire .war file due to the number of files/libraries affected,

1. Grab the patched .war file.
2. Place/replace all the configuration files from your existing .war file into the patched .war

file.

oo oo

e.

teamconnect.properties
web.xml

weblogic.xml
weblogic-application.xml
any ssl certificates

3. Redeploy the new .war file.

2. Update database and version information

Use the following steps to update the database and add patch version information to the About
page of the Admin Settings.

1. Stop the TeamConnect® instance if it is currently running.

2. Backup your TeamConnect® database.

3. Run the script, located in \update, that is appropriate for your database server:

a.
b.

MSSQL_TeamConnect_700_PatchBundle_7.sql
Oracle_TeamConnect 700 PatchBundle 7.sql

4. Restart TeamConnect®.
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UPGRADE CONSIDERATION
No significant upgrade considerations for this patch
LEVEL OF RISK TO UPDATE WITH PATCH

LOW
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